Bugs in 1st gen ac300/ac200 maybe?

?anybody hinkie about ac 300 max/ ac 200 max having 1st gen problems like ac200?
credit-card-in-bear-trap-600x360

NO bugs! NO worries!

Let’s hope I just got ac200p…its good for what I need.Anything gen 1 can be glitchy
siren

Huh. I have the AC200, the AC200P, the AC30 (x3), the AC50s (x2), the EB70 (x2)…nothing’s glitchy. They all work like a charm. Getting the EB55 this week or next. And I’m not going to miss out on the special pricing for the AC200Max, since only 500 units are being released at that price. Hobotech’s review is coming out in a few weeks. Maybe hold off on your baseless speculation til then. :roll_eyes:

I got one of the first AC200s and no bugs with mine.

well any product can and have glitches in 1st gen…they are ironed out and or upgraded ,
this is what i was thinking=Bluetti has exceptional products and i own a ac200p and=

I have the AC200 and AC200P both when the y first came out and have had no problems so far!

Will Prouse was basing that on anecdotal evidence. He did not have any problems with his. He later had a meltdown over this, because he was hammered for it. 99.9% of issues with Bluetti (and probably other sogens as well) is due to user error.

anecdotal evidence

Hi. I had my ac200p go dead after intermittent use and it would not accept a charge from any source. Bluetti is in the process of replacing it and for that i am grateful. But like you say most trouble is due to improper use. I would like to know what i did so as not to repeat the mistake. I thought that this bluetti was sort of fail proof for those of us without an electrical degree . Maybe an actual instruction video as a opposed to reviews would help